Форум успешных вебмастеров - GoFuckBiz.com

  Форум успешных вебмастеров - GoFuckBiz.com > Бизнес-решения > Скрипты, программы и технические решения
Дата
USD/RUB58.7570
BTC/USD0.0000
Скрипты, программы и технические решения Обсуждаем скрипты, программы и новые технологии.

Результаты опроса: Предпочитаемая версия php
5.2 и ниже 7 25.93%
5.3 14 51.85%
5.4 6 22.22%
Голосовавшие: 27. Вы ещё не голосовали в этом опросе

Закрытая тема
Опции темы Опции просмотра
Старый 27.11.2012, 13:22   #1
medar
кодер-энтузиаст
 
Аватар для medar
 
Регистрация: 04.04.2007
Адрес: Джамайка
Сообщений: 3,403
Бабло: $447120
По умолчанию Какую версию php используете ?

В процессе разработки одной фришной софтинки для сеошной аудитории встал вопрос, на какую версию php ориентироваться. Проблема в том, что для php 5.3 нет Zend Optimizer и те, у кого есть старые зазенденные скрипты, сидят на 5.2 . Хотелось бы узнать, каков процент таких людей и стоит ли держаться за отмирающую ветку.

Для того, чтобы узнать версию, надо в консоли ввести php -v или посмотреть в выводе функции phpinfo();

Последний раз редактировалось medar; 27.11.2012 в 13:28.
medar вне форума  
Старый 27.11.2012, 13:27   #3
medar
кодер-энтузиаст
 
Аватар для medar
 
Регистрация: 04.04.2007
Адрес: Джамайка
Сообщений: 3,403
Бабло: $447120
ТС -->
автор темы ТС По умолчанию

Опрос тут делается вторым шагом после публикации поста, добавил.
medar вне форума  
Старый 27.11.2012, 13:43   #4
Drg
Senior Member
 
Регистрация: 19.09.2009
Сообщений: 4,100
Бабло: $611505
По умолчанию

Проголосовал за 5.2 приходится держаться ею, т.к. фармапартнерки часто пишут такие шопы, что они работают только на 5.2. Да и на серваках Centos иногда не просто обновиться до того же 5.4.
Кстати,а почему Zend тормозит? я уже давно задумывался какого х. он до сих пор не выпустил для 5.3?
Drg вне форума  
Старый 27.11.2012, 13:56   #5
medar
кодер-энтузиаст
 
Аватар для medar
 
Регистрация: 04.04.2007
Адрес: Джамайка
Сообщений: 3,403
Бабло: $447120
ТС -->
автор темы ТС По умолчанию

До 5.4 обновляться, наверное, не стоит (хотя новая запись массивов - [1,2,3] вместо array(1,2,3) - это супер), стандартом сейчас уже почти везде является 5.3, он в стабильных репах лежит.

Зенд выпустил аналог - Guard Loader, но он несовместим с Optimizer, код, зашифрованный оптимайзером под ним не запустится.
medar вне форума  
Старый 27.11.2012, 14:11   #6
creator123
Senior Member
 
Аватар для creator123
 
Регистрация: 05.01.2008
Сообщений: 1,570
Бабло: $184040
По умолчанию

5.3.15
на зенд пох.
с 5.2 переход косяки были, но все решил.
creator123 вне форума  
Старый 27.11.2012, 14:52   #7
Diplomat
Senior Member
 
Аватар для Diplomat
 
Регистрация: 26.10.2009
Сообщений: 594
Бабло: $123024
По умолчанию

тоже проблема с зендом, его никак на 5.3 не поставить?
Diplomat вне форума  
Старый 27.11.2012, 16:15   #8
sspy
главный злодей гофака
 
Аватар для sspy
 
Регистрация: 18.06.2007
Сообщений: 5,305
Бабло: $879203
По умолчанию

Цитата:
Сообщение от medar Посмотреть сообщение
у кого есть старые зазенденные скрипты, сидят на 5.2 .
раззендь, делов-то

Цитата:
Сообщение от Diplomat Посмотреть сообщение
тоже проблема с зендом, его никак на 5.3 не поставить?
никак
sspy на форуме  
Старый 27.11.2012, 16:29   #9
CyberSEO
Страдаю приступами политических высеров.
 
Аватар для CyberSEO
 
Регистрация: 25.11.2012
Сообщений: 10
Бабло: $8375
По умолчанию

5.2.4
CyberSEO вне форума  
Старый 27.11.2012, 16:45   #10
oso
кодер
 
Аватар для oso
 
Регистрация: 21.01.2008
Сообщений: 316
Бабло: $69585
По умолчанию

Юзаю 5.3
Поставил 5.4, но pcre что то не заработало ( preg_match(): Compilation failed: unknown option bit(s) set at offset 0), не стал возиться.
__________________
php скрипты от $25 Отзывы: 2013-2011, 2010, 2009. acя: 384 846 ноль два шесть
oso вне форума