Форум успешных вебмастеров - GoFuckBiz.com

  Форум успешных вебмастеров - GoFuckBiz.com > Бизнес-решения > Скрипты, программы и технические решения
Дата
USD/RUB58.8280
BTC/USD0.0000
Скрипты, программы и технические решения Обсуждаем скрипты, программы и новые технологии.

Закрытая тема
Опции темы Опции просмотра
Старый 12.05.2015, 06:03   #1
igelius
Senior Member
 
Регистрация: 24.04.2013
Сообщений: 291
Бабло: $108490
По умолчанию python grab, как откатить версию?

Сейчас grab 0.6.12.
Проблема:
Код:
  File "/usr/lib/python2.6/site-packages/grab/base.py", line 368, in go
    return self.request(url=url, **kwargs)
  File "/usr/lib/python2.6/site-packages/grab/base.py", line 433, in request
    self.prepare_request(**kwargs)
  File "/usr/lib/python2.6/site-packages/grab/base.py", line 394, in prepare_request
    self.transport.process_config(self)
  File "/usr/lib/python2.6/site-packages/grab/transport/curl.py", line 335, in process_config
    self.process_cookie_options(grab, request_url)
  File "/usr/lib/python2.6/site-packages/grab/transport/curl.py", line 413, in process_cookie_options
    request_host))
TypeError: invalid arguments to setopt
Хочу 0.5.2.
igelius вне форума  
Старый 12.05.2015, 10:51   #2
masolit
Senior Member
 
Аватар для masolit
 
Регистрация: 18.08.2007
Сообщений: 1,105
Бабло: $195515
По умолчанию

pip install grab==0.5.2
masolit вне форума  
Старый 12.05.2015, 11:45   #3
lorien
Senior Member
 
Аватар для lorien
 
Регистрация: 18.05.2009
Сообщений: 879
Бабло: $177835
Отправить сообщение для lorien с помощью Skype™
По умолчанию

Дайте, плиз, код, который ошибку воспроизводит.
lorien вне форума  
Старый 12.05.2015, 12:35   #4
igelius
Senior Member
 
Регистрация: 24.04.2013
Сообщений: 291
Бабло: $108490
ТС -->
автор темы ТС По умолчанию

Цитата:
Сообщение от lorien Посмотреть сообщение
Дайте, плиз, код, который ошибку воспроизводит.
Сейчас не помню где эта ошибка возникала, с питоном 2.7.5 все завелось.
igelius вне форума  
Старый 12.05.2015, 15:52   #6
editeur
Senior Member
 
Регистрация: 27.09.2013
Сообщений: 620
Бабло: $89330
По умолчанию

Скорее всего PyCurl старый, который с уникодом не работает
http://pycurl.sourceforge.net/doc/un...ycurl-versions
editeur вне форума